New Posts New Posts RSS Feed - Swarovski Problem
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Check GunBroker.com for SWFA's No Reserve and No Minimum bid firearm auctions.

Swarovski Problem

 Post Reply Post Reply   Topic Search Topic Search  Topic Options Topic Options
Post Options Post Options   Thanks (0) Thanks(0)     Back to Top Direct Link To This Post Posted: August/16/2004 at 08:04
Reelman65 View Drop Down
Optics GrassHopper
Optics GrassHopper


Joined: August/16/2004
Status: Offline
Points: 1

I have a Swarovski 1' 6-18 adj ob. scope that i think has a problem. I have had it on 2 diferent 7mm wea mag Accu-marks and a 270 wea mag euromark. I have repeatedly checked mounts, let other people shoot and shot a total of over one hundred rounds. Also, the Euromark groups under 3/4" @ 100yds with a 3x10x42 1" swarovski. The problem with the 6x18 is that @ 100 yds it groups about 6". it seems to alternate putting shots close together in two different areas. Could there be something loose internally? if so, what is my next move.

 

thanks in advance,

Post Options Post Options   Thanks (0) Thanks(0)     Back to Top Direct Link To This Post Posted: August/16/2004 at 10:09
Chris Farris View Drop Down
TEAM SWFA - Admin
TEAM SWFA - Admin
Avatar
swfa.com

Joined: October/01/2003
Location: Texas
Status: Offline
Points: 7790
If the problem stops when you switch scopes then it sounds like your 6-18 has a problem.  Contact Swarovski at
800-426-3089
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Similar Threads: "Swarovski Problem"
Subject Author Forum Replies Last Post
There are no similar posts.
Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.176 seconds.