New Posts New Posts RSS Feed - EOTech Mounting Issues
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Check GunBroker.com for SWFA's No Reserve and No Minimum bid firearm auctions.

EOTech Mounting Issues

 Post Reply Post Reply   Topic Search Topic Search  Topic Options Topic Options
Post Options Post Options   Thanks (0) Thanks(0)     Back to Top Direct Link To This Post Posted: April/27/2007 at 12:52
jr204shot View Drop Down
Optics GrassHopper
Optics GrassHopper
Avatar

Joined: April/25/2007
Location: United States
Status: Offline
Points: 8

I just purchased a EOTech 512 to put on my flattop AR15. After following directions, I tried to see where it was with a boresight, it shows the bullet to be somewhere around 4' high? (Not enough down Travel) The instructions say to shim the sight for major adjustment. What do you use to do this? I am thinking peel shim like used in aircraft.

 

How thick should I use?

Should it be up front or at the back? I say up front.

 

Help please

rd14

          Confused

         

Post Options Post Options   Thanks (0) Thanks(0)     Back to Top Direct Link To This Post Posted: April/27/2007 at 12:59
cheaptrick View Drop Down
MODERATOR
MODERATOR
Avatar

Joined: September/27/2004
Location: South Carolina
Status: Offline
Points: 20848

4 feet high at what distance??

 

Is this just mounting the Eo on the flat top or do you have an aftermarket mount like a Larue?

 

Are you a member of AR15.com??

Post Options Post Options   Thanks (0) Thanks(0)     Back to Top Direct Link To This Post Posted: April/27/2007 at 15:23
jr204shot View Drop Down
Optics GrassHopper
Optics GrassHopper
Avatar

Joined: April/25/2007
Location: United States
Status: Offline
Points: 8

A.t 50 yards

 

EO mounted to the flat top

 

Yes

Post Options Post Options   Thanks (0) Thanks(0)     Back to Top Direct Link To This Post Posted: April/28/2007 at 15:32
jr204shot View Drop Down
Optics GrassHopper
Optics GrassHopper
Avatar

Joined: April/25/2007
Location: United States
Status: Offline
Points: 8

After reading and trying to find a answer, I went the shop where I purchased the EOTech,

They had another 512 we put on my gun it's right on money.

There is a differance in the two, and thats where the dot is in the window.

Thanks for the help, I will be sending it back to EOTech on Monday.

 

Thanks,

rd14

Post Options Post Options   Thanks (0) Thanks(0)     Back to Top Direct Link To This Post Posted: April/28/2007 at 16:16
cheaptrick View Drop Down
MODERATOR
MODERATOR
Avatar

Joined: September/27/2004
Location: South Carolina
Status: Offline
Points: 20848

I wasn't any help.

I'm glad you got the issue resolved though.

 

I have the 553 and it was almost dead nuts on my AR from the moment it came out of the box.

 

Post Options Post Options   Thanks (0) Thanks(0)     Back to Top Direct Link To This Post Posted: April/30/2007 at 12:08
Urimaginaryfrnd View Drop Down
MODERATOR
MODERATOR
Avatar
Resident Redneck

Joined: June/20/2005
Location: Iowa
Status: Offline
Points: 14268
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Similar Threads: "EOTech Mounting Issues"
Subject Author Forum Replies Last Post
There are no similar posts.
Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.237 seconds.